Plugin requirements and know issues

Mike Fitzpatrick -

Plugin requirements and known issues


Vehicle Marketing System (VMS) license(s)

DealerTrend's VMS is the core of the CarDealerPress plugin. Inventory gets to CarDealerPress from the VMS' API and is, therefore a requirement. There are different license levels based on your needs found here: CarDealerPress licenses.

PHP 5.3 or higher

Even though the most recent version of PHP is well beyond 5.3, there are several hosting companies that use 5.2 as their default. Don't worry too much about this one, so far we haven't come across a hosting company that can't upgrade to PHP 5.3 or higher. How to upgrade your PHP

WordPress header and footer

WordPress has over fourty thousand plugins and countless themes available. To help ensure that these all work as intended without conflicting with other themes and plugins, WordPress has created their codex. This codex is laid out as a how-to for developers to follow when building plugins and themes. Unfortunately, not all developers use this and therefore create products that cause compatibility issues. The most common conflict that we see is with themes that don't implement the wp_head and wp_footer functions properly (or at all). So when shopping for a theme make sure and check for these. If you already have a site up that has this issue let us know, we can usually help fix it. This applies to both the CarDealerPress plugin and our CRO/Showcase plugin.

Themeforest themes

Themeforest has some great looking themes, but most of them will cause you issues. They stuff so much functionality into them that it make it difficult to use other plugins, especially one that is as robust as the CarDealerPress plugin. Here is a good article on the subject. http://slobodanmanic.com/321/buying-themeforest-insane/

Automotive specific themes

There are several WordPress themes created for Automotive. They look great and work well for smaller independent car dealers. When you try and run the CarDealerPress plugin on one of these themes it can cause issues, though. They will compete for URI's and use the same words for javascript, etc. Since the CarDealerPress plugin handles everything you will need for inventory, using a car dealer WordPres theme is overkill. 

No Microsoft Servers

At this time we don't support Microsoft servers. When you setup your WordPress site, make sure and use a Linux server. You will find that this is the default on most shared hosting platforms. Note: We have had users have success on Microsoft Servers, but we highly discourage them even for just a WordPress site.

Godaddy Hosting

We have used Godaddy hosting in the past, and we have clients that have successfully used Godaddy for hosting. That said, we recommend against it. As a volume shared hosting platform we have seen more "mysterious" issues with Godaddy than any other hosting provider that we deal with.

Countries Served

Currently the DealerTrend Vehicle Marketing System can only "scrub" data in the U.S. and Canada. If you are looking for a tool for manual entry it should work anywhere as long as the vehicle has a VIN and Stock #. Since we haven't tested in all countries there may be some testing required to make sure that it will work for you. Suggested themes

Staging & Development

Because CarDealerPress serves dynamic inventory links based on /inventory/ as the base folder, you will want to use either a subdomain or full domain instead of subfolders.

Examples:

  • Yes: http://domain.com/inventory/Used/ 
  • Yes: http://cars.domain.com/inventory/Used/ 
  • No: http://domain.com/cars/inventory/Used/

 

If you still want to use any of the above we are limited in how we can support you. If you have an issue that is isolated to our plugin we will make the required updates. We can also help you troubleshoot but charge hourly to do so. 

Have more questions? Submit a request

Comments

Powered by Zendesk